Back to overview
Resolved

Network Latency & Ping Spikes

May 14, 2026 at 5:30am UTC  –  May 14, 2026 at 7:25am UTC
Affected services
Earth Node

Resolved
May 14, 2026 at 7:25am UTC

All previously reported issues have been resolved, and services are operating normally again.

Created
May 14, 2026 at 5:30am UTC

We are currently carrying out maintenance and optimization work on parts of our network infrastructure. During this period, users may notice:

Higher than normal ping
Temporary latency spikes
Brief connection instability
Slower response times on some services

Our engineers are actively monitoring the network and applying fixes to stabilize performance as quickly as possible. We expect services to return to normal shortly.

Thank you for your patience and understanding while we complete these improvements.